• CrouchingPython

    Thanks for that reply, and I'll look into that.

    In the meantime, I got it working by initializing the velocity and duration in the makenote object, as shown in the attached file.

    I'm happy that it works, but this makes absolutely no sense to me. If I put the velocity and duration in message boxes and hook them up, no sound. In the makenote object, voila. ???

    simple_midi_testing.pd

    posted in technical issues read more
  • CrouchingPython

    Thanks for the reply!

    Yep, I've tried every combo there I can, but still no sound.

    Interestingly, the attached file works fine, but it uses the mtof object to convert midi to frequency. So I'm guessing the problem is with something with the Windows GS Wavetable Synth or MIDI Mapper, since those are the only ones available, and I've tried them both.

    sound_test.pd

    posted in technical issues read more
  • CrouchingPython

    Just downloaded PD 0.51.1 and running it on Windows10. Got sound working right out of the box, but it has stopped working without me changing any of the preferences. I first_sequencer.pd I've attached my simple patch here. Basically it worked until I added a new message (62) to go into the makenote object. Since then, I've fiddled with different combinations of IO, MIDI, etc. to no avail. I don't know if it's something weird with GS Wavetable Synth of MIDI Mapper, or if I'm missing something super obvious.

    I did the audio/MIDI test patch, which worked, though the tone at 60 was originally a sine wave, and now sounds like noise (though I can change the pitch of the noise by changing the number in the message). Maybe that's a clue? But I get a nice middle C piano note when I click the MIDI box.

    Totally stumped right at the beginning!

    posted in technical issues read more
  • CrouchingPython

    Just an easy one for now.... I'm watching YT tutorial on PureData, hearing it fine. Trying to output sound from my patch, and hearing nothing. Tested the midi and hearing notes there, so I'm wondering if audio on YT is somehow blocking the midi output? Crazy thought, but....

    posted in this forum read more
  • CrouchingPython

    And I've actually got a MIDI controller right here, the Arturia Minilab mkII. I've chosen it on channel 1 as input and output, but not getting any sound. Sorry to be such a noob, but it's my first time with a MIDI controller and just learning Pd....

    posted in this forum read more
  • CrouchingPython

    @Load074 Derp. I remembered last night that he had set up a virtual synth on his Mac two videos before this (FM8). Doh! Wondering if there is a Win10 equivalent somewhere, and how to hook it up.... Thanks for the response!

    posted in this forum read more
  • CrouchingPython

    So a question on this.... I'm using PurrData and following Cheetomoskeeto's series of tutorials on YT. I'm on #7, Making It Work, which is about making a simple sequencer. I think I've done everything right, but not getting any sound. Sound is working, and I have DSP turned on.
    Is there some difference between PD-Extended, which the author is using in a tute recorded in 2009, and PurrData, that could be causing this problem?

    posted in this forum read more
  • CrouchingPython

    @EEight Thanks! Got it dl'ed and ready to rock.

    posted in this forum read more
  • CrouchingPython

    Just getting into PD. I teach computer science in the middle school and do several related things, like music programming with Sonic Pi, art, etc. It looks like PD is what I need to stitch all these disparate things together.

    So I'm using vanilla PD. Should I get the extended version, and which is the best one for Windows 10?

    TIA,
    Bob Irving
    Porter-Gaud School
    Charleston, SC

    posted in this forum read more
Internal error.

Oops! Looks like something went wrong!