I'm not sure if this or "technical issues" is the right forum for this, but I'm hoping that someone else here might have tried something similar and could share some expertise - and likewise, if anyone is interested in this, I'd be happy to tell you what not to do. :)

I have a project that I've been messing around with for the better part of this year that I need some advice on... I made a "box of doom" from a Raspberry Pi 2 running Pd, an Audioinjector HAT for analog signal in/out, the RPi Foundation's 7" touchscreen, and a bunch of panel-mount extension cables (USB/Audio/ethernet/power) from Adafruit. It handles audio wonderfully - very little noticeable latency from that HAT, and I highly recommend it for Pi users - but one morning I decided to do an apt-get update/upgrade, and ever since then I have not been able to get MIDI working again.

Before the update/upgrade, I was using an old Rock Band keytar controller plugged into a Mio USB-MIDI interface, and Pd recognized it as an OSS-MIDI device, no problem. Now it's not showing any OSS devices at all. Everything I've read about it sounds like ALSA is fairly straightforward and easy to set up, but after switching Pd over to ALSA and setting up the ports, I would run aconnectgui and connect my Mio's output to Pd's MIDI input, launch the testtone.pd patch, hit a few keys on the controller, and nothing. I've tried several different controllers, and all of them show up in aconnectgui, and I haven't been able to get MIDI data from them into Pd either.

I could downgrade to whatever version of Pd was available through the Raspbian repository when the first version of Stretch came out, but it sounds like I really should be using ALSA instead of OSS. I'm sure there's something I'm not doing right or something I'm forgetting, but for the life of me I can't figure out what it is. What am I doing wrong?