• Seán

    You're welcome!
    The iPad version looks like this:

    posted in patch~ read more
  • Seán

    A six-tap delay with independent control (per tap) of feedback, delay time, pitch, direction, and filter frequency. Loosely based on Rainmaker eurorack module by Intellijel, but I soon deviated to my own musical preferences. Enjoy!

    spiritditch_studio.pd

    Github link for version for iPad mini running MobMuPlat

    posted in patch~ read more
  • Seán

    I'm looking to live process a piano (for instance) and being able to change the attack time of each note. I'm not expecting to be able to do this without latency or delay. No idea where to start though, all the envelope shaping information I can find relates to synthesis and not real time mic input.
    I'm a strictly vanilla user!

    Thanks,
    Seán

    posted in technical issues read more
  • Seán

    @Balwyn That's super, works perfectly (and looks real pretty too!). I appreciate the help, I would have spent years trying to work that out.

    posted in technical issues read more
  • Seán

    Thanks for that Balwyn,
    Yes this works perfectly and I don't need to know which toggles were on only that they are all off. However in "real life" I need a version with nine toggles. So I expanded your example (perhaps incorrectly!) and it doesn't work consistently with nine.
    Any idea why?
    ninetoggles.pd

    posted in technical issues read more
  • Seán

    This little thing is evading me:
    If I have three toggles how do I calculate if each and all of them are turned off?
    I thought [int] would do it, but no!
    threenumbersintoone.jpg

    posted in technical issues read more
  • Seán

    Turns out the out of memory error was trying to tell me something after all. Once I fixed the resize issue the whole patch works - thanks a million.

    I'll share it here if it's helpful for anyone: a sound-on-sound looper with adjustable loop length and the ability to pause loop to restart it from beginning of the table.

    Seán.
    monoloop4.pd

    posted in technical issues read more
  • Seán

    Oops, yes you're right, I got the maths wrong with the resizing! The toggle isn't supposed to clear the loop as I need to be able stop loops and restart the extant loop. The mystery for me I think is why [tabwrite~] doesn't write fully into the table.
    Thanks!

    posted in technical issues read more
  • Seán

    Hi Balwyn,

    Your patch was super helpful thank you! I added a function that determines the loop length and figured everything was working - alas, it's not!
    e.g. After clearing a short loop, the next loop recorded retains the previous loop's length but I don't understand why.
    For this patch I need to be able to start the loop from its true starting point (not a continuous tape-loop style of cycle).
    Thanks again!
    monoloop3.jpg
    monoloop3.pd

    posted in technical issues read more
  • Seán

    Hello all,
    Trying to do what should (and must be!) the simplest of things: Hacking Fernando Quirós' monolooper to include overdub.
    The problem starts when I attempt to create a new layer in [tabwrite~]. This new layer also needs to include whatever is playing in [tabread~] i.e. the loops before it. How do I include the new audio signal without disrupting the original loop structure?
    MonoLooperOverdub.pd

    posted in technical issues read more
  • Seán

    Much appreciated.

    posted in technical issues read more
  • Seán

    @whale-av Thanks for that David, but looks like I'll use tables instead as [delread~] still doesn't start from the beginning point of a recently recorded loop, it just cycles around and I can't find out how to tell it to play from sample 0 of the buffer.

    posted in technical issues read more
  • Seán

    @whale-av Thanks for the reply David. I now realise how unclear my question was! In simpler terms I am looking to stop hearing a looped delay line but being able to start the loop again from its start point.
    [switch~] doesn't start audio from delread~ from the starting point of the loop for me here. I can't find any mention of being able to use [delread~] in this way.
    DelayLoopStart.pd

    posted in technical issues read more
  • Seán

    Is there a way to start a delay line using delwrite~ & delread~ from the beginning of a buffer? When using a delay line as a loop (feedback = 1) I am trying to fade out a loop and then building a function whereby I can start the loop again from its start point.
    Is this possible without resorting to tables?
    Thanks!

    posted in technical issues read more
  • Seán

    @whale-av Thanks for this. I already checked the localhost so checked that again. All is as default. I deleted saved state folder and it makes no difference. I also emptied saved state folder and made it read only so Pd can't write in there. But no dice!
    But I'm not giving up yet!

    posted in technical issues read more
  • Seán

    In this scenario I'm given the option to quit but when I do I get this message:
    (maybe this sheds light on things - it's all way over my head!)

    Not connected to 'pd' process
    Not connected to 'pd' process
    while executing
    "error "Not connected to 'pd' process""
    (procedure "pdsend" line 6)
    invoked from within
    "pdsend "pd verifyquit""
    (procedure "::tk::mac::Quit" line 2)
    invoked from within
    "::tk::mac::Quit"

    posted in technical issues read more
  • Seán

    Ok thanks. I have tried installing older versions of Vanilla with either same problem (with three newest releases) or else just a bouncing icon in the dock and a not responding warning. I'll continue the hunt around!
    Thanks,
    Seán

    posted in technical issues read more
  • Seán

    Hello!

    Can't figure out what preventing a proper install on OSX 10.8.4. I can install and run the program but all I have is Pd menu, File menu (with just 'Source' 'Hide Console' 'Clear Console' options) and Edit menu. No options to create new patch etc.
    I have Pd running without issues on another machine with more recent OSX...
    I have tried deinstalling and deleting library files.
    Help!

    posted in technical issues read more
  • Seán

    Ah ok, thanks, I did have it working in Max so I'll make a workaround. Many thanks to you both! Seán

    posted in technical issues read more
  • Seán

    @ingox Here's a patch to explain. I'm really trying to get the same one fader to respond and output the numbers of the fade up or down. If that makes sense? Your fader on the right in this patch sets the number but doesn't output it. Apologies for not 100% sense here! and thank you!
    fade_out_in.pd

    posted in technical issues read more
Internal error.

Oops! Looks like something went wrong!