Hello everyone,

I'm having a major issue at the moment. I just simply don't understand how to load in libraries into pd vanilla on my mac. As a pd-extended user, I've never had to think about this, but now it has become problematic.

I downloaded 'iemlib,' (the library responsible for the 'any' object) from dekken. I have a dedicated folder on my computer for the externals, so I store it in this folder. In pd vanilla, I go to Preferences->Path and enter the path where all the externals are located.

Now, when I try to load in the 'iemlib' library, it won't let me. I've declared it as 'declare -lib _pd-externals/iemlib' and it still refuses to work. I've tried going into preferences->startup, and typing in 'iemlib,' and it still refuses. I feel like I've tried everything that I could think of and I'm out of options here. I've been banging my head against the wall for the past few hours now.

Can anybody please run me through this process? Looking at other tutorials on the forum haven't really helped.