• sinewave

    @EEight No problem, I understand your position. Thank you for trying to keep the forum alive, it is valuable resource for both experienced and newcomers.

    posted in this forum read more
  • sinewave

    Hi,

    I am wondering why my post was deleted. Is it because the forum went down today? Not a big deal for me, I can repost it, but maybe there are more missing topics. Just a note to the forum admin...
    Cheers!

    posted in this forum read more
  • sinewave

    Hi all,

    I have some difficulties in figuring out how to correctly format MIDI notes on the pd's out. My sequencer is running in pd, sending note messages through [noteout] like this:

    [ \ ...midi note number
    |
    [$1 50(
    |
    [makenote]
    | /
    | /
    [noteout 1]

    I connected pd's Midi out to the some percussion VST in my DAW. Everything sounds and works fine, but when I try to record the midi notes coming into DAW, only the first note is recorded, although it is clearly visible and audible that DAW is receiving notes constantly.
    Has anyone experienced such problem?
    Thank you for the suggestions!

    posted in technical issues read more
  • sinewave

    Hi!

    I can't remember what's the message for changing the array's visual size. I want to create a simple zoom in/zoom out tool in pd vanilla.
    thank you!

    posted in technical issues read more
  • sinewave

    Hi there!

    Recently, I've upgraded from pd vanilla 0.43-3 to 0.44-1 and since then I can't choose ASIO Hammerfall DSP as an audio in/out.

    I found this interesting announcement from M. Puckette which says:

    _Hi all -

    Time for the first Pd 0.44 bug fix. I changed the choice of default API
    (so that MMIO is preferred to ASIO on windows; ALSA before jack on linux,
    and core audio before jack on Mac OSX - this is so that first-time Pd users
    who haven't yet chosen an API are reasonably likely to get audio on the
    first try.

    cheers
    Miller_

    Does anyone knows what I need to do to fix the problem?
    Thank you!

    posted in technical issues read more
  • sinewave

    Hi,
    this is a simple tuner abstraction (vanilla friendly). I tested it with guitar, and it seems to work fine. I couldn't fix the # (sharp) symbol issue, so it is displayed as "$" instead. Please, let me know if it needs some tweak to make it better...
    I hope someone find it useful.

    http://www.pdpatchrepo.info/hurleur/tuner.pd

    posted in abstract~ read more
  • sinewave

    Hi,

    I am trying to make an abstraction with one creation argument which can be a number or a letter. For example [my_abs 5] or [my_abs d].

    If I put [symbol $1] inside and put a number as an abstraction's creation argument, pd tells me that the object expects symbol. If I put [f $1] and put a symbol as an abstraction's creation argument, pd tells me that the object can't be created.

    It would be nice to have [anything $1]...

    What I am trying to do is kind of pc keyboard controlled switch, with the possibility to have both numeric and alphabetical key controls. [key] will be the easiest solution, since it outputs numbers only, but in that case, I will need to check which number corresponds with which key.

    Any suggestions, please?

    posted in technical issues read more
  • sinewave

    As a pd user and guitarist, I was dreaming of a open source stomp box which one can fill with his/her own pd patches. Searching the internet, I found this: http://www.shop.openstomp.com/product.sc?productId=1

    It will be really nice to use the pedal with pd, or at least, have the possibility to translate the pd patches into pedal's editing software. I am not a programmer, so I can only imagine how difficult would be to make pd work inside such box. What do you think, will it be possible?

    posted in I/O hardware diyread more
  • sinewave

    Hi,

    I can't get symbol "#" when trying to draw it on canvas. I am getting "$" instead (didn't became rich, though). Anyone has any idea how to hack that issue? The patch is in the attachment.
    Thank you!

    http://www.pdpatchrepo.info/hurleur/label_mistery.pd

    posted in technical issues read more
  • sinewave

    Hi,
    could someone suggest me a solution to fix the problem I mentioned in this post' title. I'm on winxp, pd-vanilla 0.43.0

    Thank you very much!

    posted in technical issues read more

Internal error.

Oops! Looks like something went wrong!