• amazingrolo

    oh actually I think I'm understanding it - it works if I launch the patch in the background using an ampersand, and then manually connect the ports using aconnect. it's still not really very elegant...I've seen a number of people running into this issue since the release of Stretch and PD 0.47.1. Does anyone have an explanation for why this is happening now? Is there ever any chance of it going back to being easy again?!

    posted in technical issues read more
  • amazingrolo

    thanks both for revisiting this. I'm not sure how to use those fixes though - I'm not very familiar with the command line at all! how do I use your while command to actually launch a patch?

    posted in technical issues read more
  • amazingrolo

    I've built a patch that uses the zexy "date" object, running headless on a Raspberry Pi. It works great, I'm very pleased with it.

    Currently the raspi automatically connects to a WiFi network on boot. My question is: if this WiFi network is not available, will the "date" object still work? How does it work? Is it accessing the system date on the Raspi, or is it contacting a server? How is the system date set on the Raspi? Is this reset every time the power is unplugged?

    For various reasons I'm unable to test this for myself, so I just figured I'd post this here to see if anyone knows the answer offhand!

    posted in technical issues read more
  • amazingrolo

    OK an update!

    I installed Raspbian Jessie Lite and Pure Data 0.46 and the MIDI input worked fine. So I figured the problem had to do with the "upgrade" to Stretch and PD 0.47.

    HOWEVER then I installed the software for my Pisound audio card, which is what I was using for audio input and output. This requires some sort of kernel update. After that, the MIDI stopped working again! So I'm now wondering if the problem is something to do with that kernel update. This means that Raspbian Stretch and PD 0.47 may actually be fine, but it was my Pisound software messing everything up...

    posted in technical issues read more
  • amazingrolo

    I've been doing a bunch of experiments with PD on a Raspberry Pi, with custom-built MIDI control via a Teensy microcontroller. I've been using Raspbian lite with no GUI. This was working really well until recently.

    For various reasons I updated my Raspberry Pi to the latest Raspbian (Stretch) which also allowed me to get a slightly more decent build of PD, 0.47.1.

    Since doing that I can't seem to get any MIDI input in PD, no matter what startup flags I use. Most tellingly, if I run pd -nogui -listdev I get the following list:
    audio input devices:

    1. bcm2835 ALSA (hardware)
    2. bcm2835 ALSA (plug-in)
    3. Teensy MIDI (hardware)
    4. Teensy MIDI (plug-in)
      audio output devices:
    5. bcm2835 ALSA (hardware)
    6. bcm2835 ALSA (plug-in)
    7. Teensy MIDI (hardware)
    8. Teensy MIDI (plug-in)
      API number 1

    no midi input devices found
    no midi output devices found

    --
    I find it very odd that it lists my Teensy MIDI device as an audio input and output, and also says that no midi input or output devices have been found. It is somewhat understandable that my patches will not therefore recognise any midi activity, but I don't understand why PD isn't seeing the MIDI devices.

    If I run aconnect -o I can see that the Raspberry Pi recognises the device:
    client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
    client 20: 'Teensy MIDI' [type=kernel,card=1]
    0 'Teensy MIDI MIDI 1'

    and if I run aseqdump -p 20 the MIDI data comes streaming through normally. I'm interpreting this to mean that the MIDI device is working, and the alsamidi system is working on the rPi. My only explanation is that something has changed in PD 0.47.1 to create this bug?

    I am thinking about starting from scratch and installing Raspbian Jessie instead to test and see if this works, but I'd like to avoid that if possible! Any ideas?

    posted in technical issues read more
  • amazingrolo

    Some more details, in case anyone else is able to jump in on this...running PD 0.47.1 on my Raspberry Pi headless on the latest raspbian stretch lite.

    similar to @francis666, if I run sudo pd -nogui -listdev I get the following list:
    audio input devices:

    1. bcm2835 ALSA (hardware)
    2. bcm2835 ALSA (plug-in)
    3. Teensy MIDI (hardware)
    4. Teensy MIDI (plug-in)
      audio output devices:
    5. bcm2835 ALSA (hardware)
    6. bcm2835 ALSA (plug-in)
    7. Teensy MIDI (hardware)
    8. Teensy MIDI (plug-in)
      API number 1

    no midi input devices found
    no midi output devices found

    I'm hoping to use Teensy MIDI as a USB midi device. If I run aconnect I can see the MIDI input coming in so it's definitely working, it's just not getting recognised by PD. I've tried a number of different startup flag combinations, but there's something fishy about the "no midi input devices found" message that I'm getting there. What's going on? Any ideas? I've definitely done this a number of times in the past, just using the command sudo pd -nogui -midiindev 1 midwest.pd but that now doesn't seem to work.

    The main recent change has been updating to Stretch and PD .47 from .46, is there any way that could be causing the problem?

    posted in technical issues read more
  • amazingrolo

    Hey I'm now running into the same problem...did you ever find a fix for this? I can't seem to get my USB MIDI device to be recognised no matter what combination of startup flags I use...

    posted in technical issues read more
  • amazingrolo

    @Johnny-Mauser @alexandros Thanks for the help, I got it working.

    For future people who might struggle with this (and as a help to my future self when I inevitably google this problem again), to get the zexy library working after installing it you need to define the library when you launch PD. For example:

    sudo pd -lib zexy -nogui mypatch.pd
    

    (I'm using sudo because the patch accesses the GPIO pins, and -nogui because I'm running on the command line)

    posted in technical issues read more
  • amazingrolo

    @Johnny-Mauser ah cool. do I need to do anything special to use that object on the pi? how do I install it?

    posted in technical issues read more
  • amazingrolo

    @arratik yes absolutely! those are both wonderful.

    posted in output~ read more

Internal error.

Oops! Looks like something went wrong!